AGR-Problem, Steuergerät defekt

Neu: Ab sofort könnt ihr euch DSGVO-konform für unseren Newsletter eintragen: KLICK

  • Hallo,


    im Sommer ging die Motorkontrollleuchte meinem Touareg V8 TDI an. Der Freundliche hat den Fehlerspeicher ausgelesen, P0401 Massenstrom der Abgasrückführung zu gering hieß es da. Zu Hause stellte sich dann mittels VCDS heraus, dass das AGR-Ventil Bank 2 gar nix macht. Ich habe daraufhin beide Ventile ausgebaut und mit einem AGR-Reiniger gereinigt, danach wieder das gleiche.



    Die Stellglieddiagnose ergab, dass beide Ventile funktionieren, aber nur wenn das jeweilige Ventil auf der rechten Bank angesteckt ist... ich habe mir daraufhin einen Schaltplan besorgt und die Kabel bis zum Motorsteuergerät durchgepiepst, die sind alle i.O. ... Ebenfalls komisch ist, dass der Stellerwert des funktionierenden Ventils auf 100% steht wenn das Ventil zu ist, wenn es auf ist geht er auf ~15%. Das Ventil welches nicht funktioniert, zeigt im VCDS immer 0% an. Und wohlgemerkt, es ist egal welches von den beiden Ventilen gerade auf Bank 2 angesteckt ist...


    Die einzige Möglichkeit die jetzt noch bleibt, ist ein defektes Motorsteuergerät ;(


    Gab es sowas denn schon mal hier im Forum? Ich habe noch nie ein defektes Motorsteuergerät gehabt... ich schaue jetzt mal nach einem gebrauchten Ersatz, muss ich da auf irgend etwas achten (außer natürlich dass es das richtige mit der selben Nr ist)? Muss das "neue" Steuergerät irgendwie codiert werden, müssen Sensoren darauf neu eingelernt werden, etc? Kennt sich da jemand von Euch vielleicht aus?


    Gruß, Alex

  • Hallo Alex

    Bei meinem 7L war es zumindest so, dass die Wegfahrsperre wieder codiert werden musste, was nur beim Freundlichen online ging. Ausser, man hätte vor dem Totalausfall des MStG ein Image machen können. Dann hätte man das evtl. wieder einfach aufs neue MStG aufspielen können. Aber so ein Totalausfall kündigt sich leider in den seltensten Fällen vorher an. Das ist wie mit der Schwiegermutter! ;) Die steht auch immer einfach vor der Tür!


    Schönen Sonntag, achtet auf unangekündigten Besuch!

    Martin



    Fahrzeug:

    Touareg 1; 7L V6 3.0TDI GP BJ2008; 176kW; MKB: CASA; GKB: KMB; Laufleistung: 199830 steigend

  • Hallo Martin,


    ich werde es beherzigen ^^


    Du schreibst, dass man vom Steuergerät ein Image machen und das wieder aufspielen kann? Ich wusste nicht, dass so etwas mit einem Seriensteuergerät Möglich ist... interessant! Mein Steuergerät funktioniert ja noch, außer die Ansteuerung des AGR-Ventils...


    Ich habe mal nach gebrauchten Steuergeräten geschaut. Da Experimente zu machen ist ein teures Unterfangen, und wenn es schief geht hab ich einen haufen Geld in den Wind geschossen... aber irgend etwas muss ich tun, spätestens bei der nächsten AU werde ich vermutlich Probleme bekommen...


    Gruß, Alex

  • Hallo Alex

    Bevor du viel Geld ausgiebst empfehle ich dir die Steckberbindungen zu prüfen. Bei Korrosion, verbogenen Pins/Buchsen oder defekter Verriegelung kommt das Signal nicht am Steuergerät an, obwohl das durchpiepsen geklappt hat.

    LG Manuel

  • Hallo Manuel,


    ja, das stimmt. Ich habe zwar wenig Hoffnung da das Ganze ja vorher lange Zeit funktioniert hat und die Pins optisch nicht verbogen oder korrodiert waren, ich werde aber trotzdem die Pins nochmal mit Kontaktspray einsprühen, vielleicht hilfts ja...


    Ich habe jetzt gesehen dass Bosch die Steuergeräte auch repariert (https://www.bosch-repair-servi…/edc17cp44-0281017909001/), von einem Bekannten habe ich noch die Firma Actronics genannt bekommen (https://www.actronics-gmbh.de/), mal schauen was da nun raus kommt...


    Bei beidem wäre allerdings mein Auto längere Zeit außer Gefecht gesetzt.......


    Gruß, Alex

  • gerade nochmal probiert, keine Besserung...


    was mich auch stutzig macht ist, dass auf der anderen ("gesunden") Bank bei abgezogenem Stecker der Istwert für das Ventil bei 100% steht, auf der Bank 2 bei 0%...


    Gruß, Alex

  • Ausser, man hätte vor dem Totalausfall des MStG ein Image machen können. Dann hätte man das evtl. wieder einfach aufs neue MStG aufspielen können.

    Nur mal interessehalber, macht man da ein Steuergeräteabbild mit VCDS (so wie ich verstanden habe sichert man da alle Codierungen die man nachher vermutlich auf das neue Ersatzsteuergerät wieder schreiben kann), oder meinst Du ein "richtiges" Image der gesamten Software der ECU? Wenn das sowas ist, braucht man doch bestimmt entsprechende Hard- und Software? Wie funktioniert sowas?


    Gruß, Alex

  • Ich war heute beim VW-Händler meines Vertrauens. Er meinte, dass man ein gebrauchtes Motorsteuergerät nicht so einfach freischalten kann, das kommt normalerweise fertig programmiert und codiert vom Werk. Ich habe ihm mein Problem geschildert, er meinte auch dass es sehr wahrscheinlich ist, dass mein Motorsteuergerät defekt ist. Er würde aber trotzdem vorsichtshalber gerne nochmal drüber schauen, ob nicht vielleicht doch noch etwas anderes die Ursache sein könnte. Falls es das Steuergerät sein sollte, arbeitet er mit einer Firma in Berlin zusammen, die Steuergeräte prüft und ggf. repariert. Das Ganze soll ca. 2 Wochen dauern und 300,- € kosten... Ich habe jetzt mal einen Termin in der Werkstatt ausgemacht, ich bin gespannt was nun dabei raus kommt.........


    Gruß, Alex

  • Hi Alex

    Nur mal interessehalber, macht man da ein Steuergeräteabbild mit VCDS (so wie ich verstanden habe sichert man da alle Codierungen die man nachher vermutlich auf das neue Ersatzsteuergerät wieder schreiben kann), oder meinst Du ein "richtiges" Image der gesamten Software der ECU? Wenn das sowas ist, braucht man doch bestimmt entsprechende Hard- und Software? Wie funktioniert sowas?


    Gruß, Alex

    Das kenne ich auch nur vom "HörenSagen". Wie gesagt ging das bei mir nicht.


    Bzgl der Reparatur des Steuergerätes wundert es mich, dass die da so lange dafür haben. Ich hatte meines innerhalb einer Woche wieder. Allerdings unrepariert, da Wasserschaden.


    Schönen Abend noch

    Martin



    Fahrzeug:

    Touareg 1; 7L V6 3.0TDI GP BJ2008; 176kW; MKB: CASA; GKB: KMB; Laufleistung: 199830 steigend

  • Hallo,


    mein Touareg war heute in der VW-Werkstatt. Man hat dort diverse Diagnosen durchgeführt und festgestellt, dass das AGR-System einwandfrei funktioniert :/ er meinte, dass wohl VCDS die Ventile nicht richtig ansteuert... möglicherweise wird nur Bank 1 angesteuert... ich kann mir das nur so erklären, dass der V8 ja 2 Steuergeräte hat und möglicherweise tatsächlich nur die Bank 1 ("Master") angesteuert wird... laut VW-Tester funktionieren beide Ventile einwandfrei... was allerdings nicht richtig funktioniert sind die Drallklappen... das führt auch dazu, dass die Ladedruckregelung aus dem Tritt kommt was zu dem AGR-Fehler führt... Alles sehr seltsam... er meinte, die Klappen gibt es nur zusammen mit den Saugrohren für ~2200,- € + MwSt. + Einbau... er gab mir den Hinweis, dass es wohl auch Reparaturgestänge im Zubehörhandel gibt mit denen man das reparieren kann... sehr fair, das werde ich mir jetzt die Tage mal weiter anschauen...


    Gruß, Alex

  • Kurz zur Ergänzung, ich habe heute herausgefunden dass tatsächlich nur das Ventil von Bank 1 angesteuert wird. Mann kann sich direkt auf das 2. Steuergerät unter Adresse 11 im VCDS aufschalten, dann kann man auch die Stellglieddiagnose für Bank 2 durchführen. Das ist wohl beim V8 TDI recht exotisch, da er 2 Steuegeräte hat. Leider werden einem beide Bänke zur Anzeige in den erweiterten Messwerten angezeigt, sodass man hier gehörig aufs Glatteis geführt wird wenn man das nicht weis... :(


    Jetzt muss ich weiter nach dem Fehler suchen...


    Gruß, Alex

  • Ich habe den Fehler wohl gefunden... ich habe bei der Stellglieddiagnose (Prüfung Ventil für Abgasrückführung) und bei einer Probefahrt mit mitgeloggten Daten per VCDS schon gesehen, dass die eine Bank eine höhere Luftmasse hat als die andere. Ich habe das bisher auf ein Problem in der Abgasrückführung oder bei den Drallklappen geschoben, zumal ja die Motorkontrolllampe auch wegen zu geringem Massenstrom der Abgasrückführung an ging. Bei der Prüfung der Drallklappen kommt noch hinzu, dass die Luftmassen sich gegenläufig bewegen, d.h. während die Klappen betätigt werden, geht die Massen des einen Sensors hoch ,die des anderen runter (vermutlich weil sich die Klappen gegenläufig bewegen, das muss ich noch rausfinden, bisher fehlte mir der 2. Mann bei der Prüfung).


    Das alles hat mich jetzt doch mal dazu veranlasst, die HFM's einfach mal bankweise zu tauschen. Und siehe da, die geringere Luftmasse ist mit dem HFM mitgewandert... und schwupp diwupp ging auch die Motorkontrollampe aus... also habe ich 2 neue HFMs eingebaut, was ergab, dass tatsächlich der eine zu wenig angezeigt hat.


    Nun habe ich außerdem noch rausgefunden, dass der Massenstrom der Abgasrückführung aus dem Massenstrom der HFMs und dem Drucksensor am AGR-Ventil berechnet wird. Und wenn der Luftmassenstrom zu klein ist, ist ergo auch der AGR-Massenstrom zu gering...


    Eine kurze Schrecksekunde gab es noch, als bei der ersten Probefahrt nach dem Austausch der Verbrauch plötzlich bei 25L/100km lag... die Lösung war, dass das Steuegergerät alle Kennfelder auf den zu niedrig messenden HFM gelernt hat und man die Lernkennfelder über das VCDS wieder zurücksetzen musste und schon war der ganze Spuk vorbei...


    Gruß, Alex